Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Mensajes - pedro,,

Páginas: [1] 2 3 4 5 6 ... 65
1
Hola paramonso. La solución que presentas está correcta. Saludos. ;D

2
Buenas paramonso. Ejercicio bien resuelto. Saludos.  ;D

3
Buenas.


Respuestas correctas.

Saludos. ;D

4
Buenas KFZ_10

El apartado a no es correcto. El enunciado habla de tres valores interruptores y has creado 7 variables. Una respuesta correcta sería crear tres variables de tipo boolean o int como se comenta en la unidad.

El apartado b, podría ser correcto, pero los nombres que usan no son descriptivos, quedarían más descriptivos si uno se llamase radioEsfera  y el otro volumenEsfera. Es aconsejable que los nombres sean descriptivos para que cueste menos leer el código.

Apartado c bien.

En el apartado d, solo necesitaríamos una variable para la cantidad de hermanos que  tenemos y si se quisiese otra más que represente el numero de hermanos en total incluyéndonos.

Saludos. ;D

5
Hola José Manuel.

Para poder ayudarte tendrías que exponer los pasos que has seguido y así poder ver donde está el fallo.

Saludos. ;D

7
Buenas paramonso. Todo bien. Saludos. ;D

8
De todo un poco... / Re:[PSEINT] Ayuda sobre lógica
« : 29 de Julio 2017, 12:16 »
Buenas prOjectz

Te dejo un ejemplo de como lo orientaría yo.

Código: [Seleccionar]
Algoritmo Cajero

Escribir "Inserte la cantidad de billetes de 500 que contendrá el cajero: "
Leer cantidadDe500
saldo = 500 * cantidadDe500
Escribir "Inserte la cantidad de billetes de 200 que contendrá el cajero: "
Leer cantidadDe200
saldo = saldo + (cantidadDe200 * 200)
Escribir "Inserte la cantidad de billetes de 100 que contendrá el cajero: "
Leer cantidadDe100
saldo = saldo + (cantidadDe100 * 100)
Escribir "Inserte la cantidad de billetes de 50 que contendrá el cajero: "
Leer cantidadDe50
saldo = saldo + (cantidadDe50 * 50)

Si saldo>0 Entonces


Si saldo < 5000 Entonces
Escribir "IMPORTANTE! Puede retira hasta $", saldo, " y en múltiplos de $50"
SiNo

Escribir "IMPORTANTE! Puede retira hasta $5000 y en múltiplos de $50"
FinSi

Repetir
Escribir "Ingrese el monto que desea extraer:" Sin Saltar
Leer extraccion
Borrar Pantalla
Si (extraccion MOD 50) <> 0 Entonces
Escribir "# ERROR: El valor ingresado no es múltiplo de $50"
FinSi
Si (extraccion > 5000) Entonces
Escribir "# ERROR: El valor ingresado supera el límite de $5000"
FinSi
Si extraccion > saldo Entonces
Escribir "** No hay saldo suficiente, puede retirar hasta: $",saldo
FinSi
Hasta Que (extraccion <= 5000) y (extraccion <= saldo) y (extraccion MOD 50 = 0)

Si extraccion >= 500 Entonces
billete500 = TRUNC(extraccion / 500)
Si billete500 > cantidadDe500 Entonces
extraccion = extraccion - (cantidadDe500 * 500)
billete500 = cantidadDe500
SiNo
extraccion = extraccion - (billete500 * 500)
FinSi
FinSi

Si extraccion >= 200 Entonces
billete200 = TRUNC(extraccion / 200)
Si billete200 > cantidadDe200 Entonces
extraccion = extraccion - (cantidadDe200 * 200)
billete200 = cantidadDe200
SiNo
extraccion = extraccion - (billete200 * 200)
FinSi
FinSi

Si extraccion >= 100 Entonces
billete100 = TRUNC(extraccion / 100)
Si billete100 > cantidadDe100 Entonces
extraccion = extraccion - (cantidadDe200 * 100)
billete100 = cantidadDe100
SiNo
extraccion = extraccion - (billete100 * 100)
FinSi
FinSi

Si extraccion >= 50 Entonces
billete50 = TRUNC(extraccion / 50)
Si billete50 > cantidadDe50 Entonces
extraccion = extraccion - (cantidadDe200 * 50)
billete50 = cantidadDe50
SiNo
extraccion = extraccion - (billete100 * 50)
FinSi
FinSi

Escribir "La cantidad proporcionada es: "
Escribir billete500, " billete de $500"
Escribir billete200, " billete de $200"
Escribir billete100, " billete de $100"
Escribir billete50, " billete de $50"

SiNo

Escribir "** NO HAY DINERO ~ FUERA DE SERVICIO **"
Escribir ""

FinSi

FinAlgoritmo


Saludos. ;D

9
Hola paramonso.

El apartada a bien.

El apartado b  dice que tiene que recibir como parámetro la ruta de un fichero, y en tu código lo que hace es recibir la referencia de un archivo abierto. Eso sería lo único a corregir.

Saludos. ;D

10
Buenas.

Como bien dices en php no es necesario declarar ni iniciar las variables, hasta ahí todo bien.

Lo que quería decir, es
¿que sentido tiene que mandes un parámetro a una función del cuál no se va hacer uso, en este caso?

Porque en la función obtenerSuma estás mandado el valor que contenga "$TotalSuma", es decir, nada. Además de que no comete ninguna tarea dentro de la función.


Saludos. ;D

11
Buenas.

Cosas a corregir:

El código quedaría mejor ordenado si la apertura y cierre de los archivos se hicieran dentro de cada función, quedando fuera de las funciones sólo el código necesaria para hacer las llamadas a las funciones y mostrar los resultados.

Cuando llamas a la función obtenerSuma, le pasas dos parámetros, uno con la ruta del archivo y otro que llamas $TotalSuma que no tiene ningún valor puesto que anteriormente no lo has definido, en la función obtenerArrNum te pasa igual, la variable $Array no contiene nada.


Saludos. ;D

12
Hola paramonso.

Ahora funciona, aunque no estás usando de forma correcta el select, de la forma que lo estás usando se pueden enviar tres "name" distintos, con lo que en el supuesto archivo recibe.php tendrías que intentar recoger el valor de cada uno de ellos y averiguar cual de ellos se ha enviado, y lo ideal es que el atributo "name" se los asignes a la etiqueta select, de esta forma solo tendrás que preguntar por el nombre de esa propiedad y no por tres, aunque esto lo verás más clara más adelante en el curso.

En tú código tienes lo siguiente:
Código: [Seleccionar]
<SELECT name="opcEnvio">
<OPTION name="opcNormal">Normal</OPTION>
<OPTION name="opcAvion">Avion</OPTION>
<OPTION name="opcUrgente">Urgente</OPTION>
</SELECT>

Y debería quedar así:
Código: [Seleccionar]
<select name="opcEnvio">
<option>Normal</option>
<option>Avion</option>
<option>Urgente</option>
</select>

Saludos. ;D

13
Buenas.

Se me pasó comentarte que debes usar el método nextLine() y no el método next(), puesto que este si encuentra un espacio en blanco lo toma como fin de la cadena introducida.

Cambia esta línea:
Código: [Seleccionar]
entrada=nuevocantante.next();
Por esta otra:
Código: [Seleccionar]
entrada=nuevocantante.nextLine();
Saludos. ;D

14
Buenas joher60.

El problema que te ocurre es debido a que estás intentado comparar en el if de la función liquido una variable que no ha sido declarada anteriormente, que es "alcet".

La solución sería declararla antes.

Ya que no has dejado código completo, te paso el código que he elaborado para hacer las pruebas.
Código: [Seleccionar]
<!DOCTYPE html>
<html>
    <head>
        <meta name="viewport" content="initial-scale=1.0, user-scalable=no">
        <meta charset="utf-8">
        <title>Ejemplo</title>
        <script>

          var a="1.- ";
          var b="2.- ";
          var c="3.- ";
          var d="4.- ";
          var e="5.- ";
          var f="6.- ";
          var g="7.- ";
          var h="8.- ";
          var i="9.- ";
          var j="10.- ";
          var k="11.- ";
          var l="12.- ";
          var m="13.- ";
          var n="14.- ";
          var o="15.- ";

          var br="<br>";
          var ml=" Mililitros";
          var li=" Litros";
          var gr=" Gramos";
          var mg=" Miligramos";
          var kl=" Kilogramos";

          var tca="Para hacer ";
          var tcc=" se requieren:"

          var nagu = "Agua - H2O = ";
          var ntexa = "Texapon N-70 Lauril Sulfato de Sodio = ";
          var alcet = 0;

          function entrada(){
            if(UI=document.getElementById('entradaPrueba')){
              prueba();
            } else if(UI=document.getElementById('entradaPruebaB')) {
              pruebaB();
            } else if(UI=document.getElementById('entradaPruebaC')) {
              pruebaC();
            }
          }

          function liquido(UI){
            if (UI<=1){
              tcb=" Litro de ";
              agu = agu*1000 + ml;
              texa = texa*1000 + gr;
            } else {
              tcb=" Litros de ";
              if (agu*1000>=1000){
                agu=agu+li;
              }else{
                agu=agu*1000+ml;
              };
              if (texa*1000>=1000){
                texa=texa+kl;
              }else {
                texa=texa*1000+gr;
              };
              if (alcet == undefined) {
                alcet == 0;
              } if (alcet*1000>=1000){
                alcet=alcet+kl;
              }else {
                alcet=alcet*1000+gr;
              };
            }
          }

          function prueba() {
            var UI=document.getElementById('entradaPrueba').value;
            if(isNaN(UI)){
              return false;
            }
            producto = "Producto de Prueba";
            agu = UI*91.8/100;
            texa = UI*3/100;
            liquido(UI);
            resul = tca+UI+tcb+producto+tcc+br+a+nagu+agu+br+b+ntexa+texa+br;

            var procedimiento="<h1>PROCEDIMIENTO:</h1> PRODUCTO DE PRUEBA";

            document.getElementById('salida').innerHTML=resul,
            document.getElementById('procedimiento').innerHTML=procedimiento;
          }

        </script>
    </head>
<body>
   <input type="text" id="entradaPrueba" /><input type="button" name="boton" id="boton" onclick="entrada();" value="Empezar" />
   <div id="procedimiento"></div>
   <div id="salida"></div>


</body>
</html>


Y si estás empezando con JavaScript, aquí te dejo un enlace con un gran curso gratuito para aprender desde 0.

http://aprenderaprogramar.com/index.php?option=com_content&view=category&id=78&Itemid=206

Y si estás interesados en otros cursos, aquí te paso otro enlace donde hay más cursos:

http://aprenderaprogramar.com/index.php?option=com_content&view=article&id=57&Itemid=86

Saludos.  ;D

15
Buenas.

El problema que tiene la función liquido, es que no reconoce el valor de "UI" debido a que esta variable está en otro ámbito, esto lo puedes solucionar pasándole el valor de "UI" como parámetro cuando llames a la función.

Código: [Seleccionar]
liquido(UI);
y la función líquido debe de quedar de la siguiente forma:


Código: [Seleccionar]
function liquido(UI){
if (UI<=1){
tcb=" Litro de ";}
else {tcb=" Litros de ";}
}

En cuanto a lo que dice Kabuto, al no declarar la variable con "var" dentro de las funciones donde se encuentra,  su ámbito es global.
Habría que cambiar muchas cosas en el código, puesto que tiene como unas 25 variables declaradas con ámbito local y esto es consumir recursos innecesariamente.

Saludos.  ;D

16
Buenas.

Todo lo que envía un formulario debe de contener el atributo "name", y la lista no tiene este atributo establecido, de ahí que no aparezca en la url.

Saludos. ;D

17
Buenas Luis. Buenas respuestas. Solo comentar que hasta la api 7 de Java (incluida), la interface Iterable solo contenía el método iterator() y en la versión 8 aparecieron los otros dos que mencionaste.

Saludos. ;D

18
Buenas Alber.


El ejercicio es correcto.

Para solucionar tu duda puedes añadir lo siguiente dentro del bucle while:

Código: [Seleccionar]
if (!entrada.equals("fin")) {
cantantesFamosos.addNombre(entrada);
}

Saludos.  ;D

19
Hola joher60

Para poder ayudarte sería bueno que pegases el código completo y explicases que es lo que debe de hacer.

Saludos. ;D

20
De todo un poco... / Re:Ayuda con PHP
« : 22 de Julio 2017, 21:35 »
Hola Telecowill

Si el archivo se llamase index.php si lo abriría directamente.

Cuando introduces la url que te asignaron, el servidor busca un archivo index.php o index.html, o algún otro nombre, esto dependerá del servidor.

Saludos.  ;D

Páginas: [1] 2 3 4 5 6 ... 65
Esto es un laboratorio de ideas...
Aprender a programar

Preguntas y respuestas

¿Cómo establecer o cambiar la imagen asociada (avatar) de usuario?
  1. Inicia sesión con tu nombre de usuario y contraseña.
  2. Pulsa en perfil --> perfil del foro
  3. Elige la imagen personalizada que quieras usar. Puedes escogerla de una galería de imágenes o subirla desde tu ordenador.
  4. En la parte final de la página pulsa el botón "cambiar perfil".