Autor Tema: Ayuda con pseudocodigo  (Leído 3658 veces)

corr

  • Sin experiencia
  • *
  • APR2.COM
  • Mensajes: 2
    • Ver Perfil
Ayuda con pseudocodigo
« en: 12 de Octubre 2022, 09:27 »
Buenas, estoy intentando simular un estacionamiento, simulando entradas y salidas con 3 arreglos los cuales son a, b y c con una dimension de 6 cada uno. Al momento de que el LOTE A se llene al 50%, osea 3, se tendria que llamar a la funcion C para que proceda a llenarse por completo y una vez que se llene el LOTE C, llamar a la funcion B para que se llene por completo el LOTE B y ya que se llene el LOTE B, ahora si terminar de llenar el LOTE A. Una vez que ya esten llenos los 3 LOTES, ahora si, ya puedo eliminar cualquiero posicion de cualquier lote simulando las salidas del estacionamiento y eso seria todo.

Hasta ahora esto es lo que llevo, cualquier consejo o algoritmo que tengan que me ayude, se los agradeceria mucho.

Código: [Seleccionar]
Funcion ArregloC ( c )

Fin Funcion

Funcion ArregloB( b )

Fin Funcion

Funcion ArregloA ( a )
definir i, valorr, posicion, c Como Entero
c=0
valorr = 1
repetir
Limpiar Pantalla
Escribir "LOTE A: Casillas del 1 al 6"
leer posicion
si posicion < 1 y posicion > 6 Entonces
escribir "Posicion incorrecta"
FinSi
Limpiar Pantalla
Hasta Que posicion >= 1 y posicion <= 6
a[posicion] = valorr
Escribir "Su lugar de estacionamiento es: Lote A, Casilla: |",posicion,"|"
Escribir ""
para i=1 Hasta 6 con paso 1 Hacer
Escribir Sin Saltar " | "
Escribir Sin Saltar a[i] " | "
FinPara
Escribir ""
Escribir ""
Escribir "--------------------------------"
Fin Funcion

Algoritmo ProyectoUnidad2TEST
Definir opc, lote Como Entero
Dimension a[6], b[6], c[6]
Repetir
Escribir "|| Estacionamiento *La Mosca* ||"
Escribir "1.- Ingresar"
Escribir "2.- Salir"
Escribir "// Comando administrativo //"
Escribir "3.- Cierre"
Escribir "Opcion: "Sin Saltar
Leer  opc
Segun opc Hacer
1:Limpiar Pantalla
Repetir
Escribir "Lote al que desea ingresar"
Escribir "   A(1) / B(2) / C(3)     "
leer lote
Segun lote Hacer
1:
ArregloA(a)
2:
ArregloB(b)
3:
ArregloC(c)
De Otro Modo:
Escribir "Porfavor seleccione SOLO las opciones disponibles"
Escribir ""
FinSegun
Hasta Que lote >= 1 y lote <= 3
2:

3: Limpiar Pantalla
Escribir "Cerrando programa"
De Otro Modo:
Limpiar Pantalla
Fin Segun
hasta que opc = 3
FinAlgoritmo
« Última modificación: 12 de Octubre 2022, 12:45 por Mario R. Rancel »

corr

  • Sin experiencia
  • *
  • APR2.COM
  • Mensajes: 2
    • Ver Perfil
Re: Ayuda con pseudocodigo
« Respuesta #1 en: 12 de Octubre 2022, 09:28 »
Todo eso, lo estoy realizando en PSeint.

Kabuto

  • Moderador Global
  • Experto
  • *******
  • Mensajes: 988
    • Ver Perfil
Re: Ayuda con pseudocodigo
« Respuesta #2 en: 12 de Octubre 2022, 12:09 »
Hola.

Pues de momento parece que vas bien.
El siguiente paso sería comprobar si la posición que ha indicado el usuario, está libre u ocupada antes de asignársela.
Y después de eso, otro paso será comprobar si el lote A está ya al 50%, para ver si hay que derivarlo a los otros lotes.
NO respondo dudas por mensaje privado
Publicando vuestras dudas en el foro público conseguimos:
- Que más gente aporte respuestas mejores o complementarias.
- Que otras personas puedan aprender de vuestras dudas.

Mejor en PÚBLICO que en privado. Gracias

 

Sobre la educación, sólo puedo decir que es el tema más importante en el que nosotros, como pueblo, debemos involucrarnos.

Abraham Lincoln (1808-1865) Presidente estadounidense.

aprenderaprogramar.com: Desde 2006 comprometidos con la didáctica y divulgación de la programación

Preguntas y respuestas

¿Cómo establecer o cambiar la imagen asociada (avatar) de usuario?
  1. Inicia sesión con tu nombre de usuario y contraseña.
  2. Pulsa en perfil --> perfil del foro
  3. Elige la imagen personalizada que quieras usar. Puedes escogerla de una galería de imágenes o subirla desde tu ordenador.
  4. En la parte final de la página pulsa el botón "cambiar perfil".