Autor Tema: evaluar varias condiciones en excel como if anidados (anidar condicionales)  (Leído 50138 veces)

Lola Roches

  • Sin experiencia
  • *
  • Mensajes: 33
    • Ver Perfil
Hola! Estoy tratando de crear un condicional en excel pero no para evaluar una sola condición sino para evaluar varias como si fueran if anidados ¿alguna sugerencia sobre cómo se hace esto?
« Última modificación: 03 de Agosto 2017, 18:19 por César Krall »

Mastermind

  • Experto
  • *****
  • Mensajes: 540
    • Ver Perfil
Re:evaluar varias condiciones en excel como if anidados
« Respuesta #1 en: 24 de Junio 2013, 12:33 »
Si (condicion1) Entonces
    Si (condicion2) Entonces
        Si (condicion3) Entonces
            Instrucciones a ejecutar
        FinSi
    FinSi
FinSi

Lola Roches

  • Sin experiencia
  • *
  • Mensajes: 33
    • Ver Perfil
Re:evaluar varias condiciones en excel como if anidados
« Respuesta #2 en: 25 de Junio 2013, 08:18 »
En realidad lo que quiero hacer es como esto:

Si (condicion1) Entonces
    escribir texto1
Sino Si (condicion2) Entonces
           escribir texto2
         Sino Si (condicion3) Entonces
                         escribir texto3
                   FinSi
         FinSi
FinSi

Pero claro escribirlo en pseudocodigo no me sirve, lo que quiero es la sintaxis que habría que usar en excel para que se ejecute esto.

Supongamos que quiero evaluar si en la celda A1 está la letra a y en caso afirmativo escribir en la celda B1 11 y en caso negativo "no contiene a". En este caso la sintaxis es:

=SI(A1="a"; 11; "No contiene a")

Esta es la condición simple, he tratado de escribir el anidamiento pero me da error.
             

Alex Rodríguez

  • Moderador Global
  • Experto
  • *******
  • Mensajes: 2054
    • Ver Perfil
Re:evaluar varias condiciones en excel como if anidados
« Respuesta #3 en: 01 de Julio 2013, 08:30 »
Lola prueba con esta sintaxis:

=SI(H1="a";11;SI(H1="b";22;SI(H1="c";33)))

Aquí se supone que estamos situados en por ejemplo la celda M1 y estamos evaluando el contenido de la celda H1. Si el contenido de la celda H1 es a, el contenido de la celda M1 será 11, si el contenido de la celda H1  es b, el contenido de la celda M1 será 22, y si el contenido de la celda M1 es c, el contenido de la celda M1 será 33.

Lola Roches

  • Sin experiencia
  • *
  • Mensajes: 33
    • Ver Perfil
Re:evaluar varias condiciones en excel como if anidados
« Respuesta #4 en: 02 de Julio 2013, 11:04 »
gracias Alex, va perfecto

jockattan

  • Sin experiencia
  • *
  • APR2.COM
  • Mensajes: 2
    • Ver Perfil
Re:evaluar varias condiciones en excel como if anidados
« Respuesta #5 en: 25 de Noviembre 2014, 21:11 »
Hola Alex,.. o alguno que me pueda ayudar..
Necesito ingresar una condición en Excel indicando "empieza por", es como decir: si empieza por " XXX","SI","NO".
Gracias,

Alex Rodríguez

  • Moderador Global
  • Experto
  • *******
  • Mensajes: 2054
    • Ver Perfil
Re:evaluar varias condiciones en excel como if anidados
« Respuesta #6 en: 25 de Noviembre 2014, 23:31 »
Hola, dado que la cuestión que se trataba aquí estaba resuelta, por favor abre un nuevo tema de modo que se trate como una consulta nueva (este tema lo damos por cerrado). Saludos.

 

Sobre la educación, sólo puedo decir que es el tema más importante en el que nosotros, como pueblo, debemos involucrarnos.

Abraham Lincoln (1808-1865) Presidente estadounidense.

aprenderaprogramar.com: Desde 2006 comprometidos con la didáctica y divulgación de la programación

Preguntas y respuestas

¿Cómo establecer o cambiar la imagen asociada (avatar) de usuario?
  1. Inicia sesión con tu nombre de usuario y contraseña.
  2. Pulsa en perfil --> perfil del foro
  3. Elige la imagen personalizada que quieras usar. Puedes escogerla de una galería de imágenes o subirla desde tu ordenador.
  4. En la parte final de la página pulsa el botón "cambiar perfil".