Pseudocódigo y diagrama de flujo ecuación cuadrática (2º grado). Si entonces sino, if then else (CU00143A)

Resumen: Entrega nº 42 del curso Bases de la programación Nivel I.
Codificación aprenderaprogramar.com: CU00143A

 

 

 

EJERCICIO EJEMPLO RESUELTO

Crear el pseudocódigo y el diagrama de flujo para un programa que pida un número entero distinto de cero y nos muestre en pantalla un mensaje indicándonos si el número es par o impar.

 

 

SOLUCIÓN

 

Pseudocódigo

y

diagrama de flujo

1. Inicio [Pseudocódigo aprenderaprogramar.com]

2. Mostrar “Introduzca un número” : Pedir Num

3. Res = Num mod 2

4. Si Res = 0 Entonces

Mostrar “El número es par”

SiNo

Mostrar “El número es impar”

FinSi

5. Fin

 

 

 


Nota: Hemos considerado las instrucciones comprendidas entre el Si ... y el FinSi como inseparables, por lo que cuentan como única línea.

 

 

EJERCICIO EJEMPLO RESUELTO: ECUACIÓN CUADRÁTICA

Crear el pseudocódigo y el diagrama de flujo para un programa que resuelva la ecuación cuadrática tipo ax2 + bx + c.

 

 

SOLUCIÓN

Problema no tan inmediato como el anterior. Hay que tener muy claro qué se quiere hacer. Así planteamos:

1. Objetivos: obtención de las raíces reales o imaginarias para la ecuación tipo.

2. Condicionantes: parámetros a, b, c.

3. Datos de partida: parámetros a, b, c.

4. Método o estrategia de resolución: resolución documentada.

5. Resultados a obtener: raíces x1 y x2 de la ecuación.

 

 

Documentación:

La solución general viene dada por:

Con las siguientes particularidades en función del radicando :

X1,2 = ( -b ± SQR(b2 - 4ac) ) / 2a

 

a) Cuando > 0 existen dos raíces reales:

X1 = ( -b + SQR(b2 - 4ac) ) / 2a              X2= ( -b - SQR(b2 - 4ac) ) / 2a

 

b) Cuando = 0 existe una raíz real:

X1 = X2 = -b / 2a

 

c) Cuando < 0 las dos raíces son imaginarias:

X1 = (-b / 2a) + (SQR(d) / 2a) · i             X1 = (-b / 2a) - (SQR(d) / 2a) · i

 

donde d = b2 - 4ac   e i la unidad imaginaria, mientras que SQR indica la operación de raíz cuadrada.

 

 

Diagrama de flujo:

 

 

 

Pseudocódigo:

1. Inicio [Pseudocódigo aprenderaprogramar.com]

2. [Resolución de ecuación cuadrática ax2 + bx + c = 0]

3. Mostrar “Introduzca los valores de parámetros”

4. Pedir a, b, c

5. d = b ^ 2 - 4 * a * c : e = 2 * a

6. Si d = 0 Entonces

Mostrar “x1 = x2 =”, - b / e

SiNo

Si d > 0 Entonces

Mostrar “x1 =”, (- b + SQR(d)) / e

Mostrar “x2 =”, (- b - SQR(d)) / e

SiNo

Mostrar “x1 =”, - b / e, “+”, SQR(- d) / e, “i”

Mostrar “x2 =”, - b / e, “-”, SQR(- d) / e, “i”

FinSi

FinSi

7. Fin

Nota: SQR significa "raíz cuadrada". 

 

 

 

 

 

 

Para acceder a la información general sobre este curso y al listado completo de entregas pulsa en este link:  Ver curso completo.

Para  hacer un comentario o consulta utiliza los foros aprenderaprogramar.com, abiertos a cualquier persona independientemente de su nivel de conocimiento.

¿Puedo yo aprender?

Seas o no del área informática, si quieres aprender a programar te ofrecemos una solución guiada y personalizada: realizar un curso tutorizado on-line. Con este tipo de curso, podrás aprender a programar de forma ágil y amena.

Acceder a detalles y precios de los cursos tutorizados on-line

Política sobre cookies

Utilizamos cookies propias y de terceros para ofrecerte una mejor experiencia y servicio, de acuerdo a tus hábitos de navegación.

Si continúas navegando, consideramos que aceptas su uso. Puedes obtener más información en nuestra Política de Cookies.

En Facebook!

Ahora puedes seguirnos en Facebook. Noticias, novedades y mucho más ¡Te esperamos!

RANKING APR2+

Ranking de lenguajes y entornos de programación aprenderaprogramar.com
 

MARZO - ABRIL 2017

1. Java / J2EE
2. Entornos Oracle
3. JavaScript, jQuery
4. .NET, C#
5. Entornos SQL Server
6. HTML, CSS
7. Php, MySql
8. Android, iOS


Acceder a detalles sobre el ranking de programación aprenderaprogramar.com

FOROS APR2+

Pregunta, responde, consulta, lee, intercambia...

Participa!!! Entra en los foros aprenderaprogramar.com.

             Copyright 2006-2017 aprenderaprogramar.com                La web abierta a cualquier persona interesada en la programación