Ejercicio ejemplo algoritmo de operaciones (añadir, borrar...) con listas de datos en pseudocódigo I (CU00219A)

Resumen: Entrega nº18 del curso Bases de la programación Nivel II.
Codificación aprenderaprogramar.com: CU00219A

 

 

EJERCICIO EJEMPLO ALGORITMO PARA MANEJO DE LISTA DE DATOS

Desarrollar un algoritmo para el manejo de una lista de datos que ofrezca las siguientes opciones:

· Añadir un dato.

· Borrar un dato.

· Conocer el número de datos que existe en la lista.

· Mostrar los datos que existan en la lista.

· Salir del programa.

Anagrama aprenderaprogramar.com

 

SOLUCIÓN

Pseudocódigo:

PROGRAMA DATOS01 [Pseudocódigo aprenderaprogramar.com]

 

Variables

Enteras: E

Reales: Dato()

 

1. Inicio

2. Mientras E <> 5 Hacer

     2.1 Si E = 1 Entonces

          Llamar Añadir

          FinSi

     2.2 Si E = 2 Entonces

           Llamar Borrar

           FinSi

     2.3 Si E = 3 Entonces

          Mostrar “El número de datos actualmente en la lista es de”, Limitesuperior (Dato)

          FinSi

     2.4 Si E = 4 Entonces

          Llamar Listar

          FinSi

     2.5 Mostrar “Elija una opción.   1. Añadir dato.

                                                 2. Borrar dato.

                                                 3. Conocer el total de datos.

                                                 4. Mostrar Lista.

                                                 5. Salir.”

     2.6 Pedir E

     Repetir

3. Fin

 

Módulo Añadir

1. Redimensionar Dato(Limitesuperior(Dato) + 1)

2. Mostrar “Introduzca valor a añadir”

3. Pedir Dato(Limitesuperior(Dato))

FinMódulo

 

Módulo Borrar

Variables

Enteras: i, Numborrar

1. Si Limitesuperior(Dato) <> 0 Entonces

     1.1 Numborrar = 0

     1.2 Mientras Numborrar < 1 ó Numborrar > Limitesuperior(Dato) Hacer

               Mostrar “Introduzca el nº de dato a borrar”

               Pedir Numborrar

          Repetir

     1.3 Si Numborrar < Limitesuperior(Dato) Entonces

               Desde i = Numborrar hasta Limitesuperior(Dato) – 1

                    Dato(i) = Dato(i + 1)

               Siguiente

          FinSi

     1.4 Redimensionar Dato(Limitesuperior(Dato) – 1)

     1.5 Mostrar “Dato borrado”

     FinSi

2. Si Limitesuperior(Dato) = 0 Entonces

          Mostrar “La lista está vacía”

     FinSi

FinMódulo

 

Módulo Listar [Pseudocódigo aprenderaprogramar.com]

Variables

Enteras: i

1. Desde i = 1 hasta Limitesuperior(Dato) Hacer

     Mostrar Dato(i)

Siguiente

FinMódulo

 

 

Listas en programación

 

 

Diagrama de flujo programa if then

 

 

 

 

 

 

Para acceder a la información general sobre este curso y al listado completo de entregas pulsa en este link:  Ver curso completo.

 Para  hacer un comentario o consulta utiliza los foros aprenderaprogramar.com, abiertos a cualquier persona independientemente de su nivel de conocimiento.

¿Puedo yo aprender?

Seas o no del área informática, si quieres aprender a programar te ofrecemos una solución guiada y personalizada: realizar un curso tutorizado on-line. Con este tipo de curso, podrás aprender a programar de forma ágil y amena.

Acceder a detalles y precios de los cursos tutorizados on-line

Política sobre cookies

Utilizamos cookies propias y de terceros para ofrecerte una mejor experiencia y servicio, de acuerdo a tus hábitos de navegación.

Si continúas navegando, consideramos que aceptas su uso. Puedes obtener más información en nuestra Política de Cookies.

En Facebook!

Ahora puedes seguirnos en Facebook. Noticias, novedades y mucho más ¡Te esperamos!

RANKING APR2+

Ranking de lenguajes y entornos de programación aprenderaprogramar.com
 

JULIO - AGOSTO 2017

1. Java / J2EE
2. Entornos Oracle
3. Entornos SQL Server
4. JavaScript, jQuery
5. .NET, C#
6. HTML, CSS
7. Android, iOS
8. Php, MySql


Acceder a detalles sobre el ranking de programación aprenderaprogramar.com

FOROS APR2+

Pregunta, responde, consulta, lee, intercambia...

Participa!!! Entra en los foros aprenderaprogramar.com.

             Copyright 2006-2017 aprenderaprogramar.com                La web abierta a cualquier persona interesada en la programación