Ejercicio serie suma términos de una sucesión y multiplicación de n impares Pseudocódigo I (CU00217A)

Resumen: Entrega nº16 del curso Bases de la programación Nivel II.
Codificación aprenderaprogramar.com: CU00217A

 

 

EJERCICIO PRESCINDIENDO DEL USO DE ARRAYS

Desarrollar el pseudocódigo y el diagrama de flujo para un programa con las siguientes opciones:

a)   Introducir un valor entero impar comprendido entre 1 y 19

b)   Calcular la serie numérica 1 + 3 + 5 + ··· + n

c)   Calcular 1 * 3 * 5 * ··· * n

d)   Salir del programa.

 

Nota: Ya hemos explicado la solución de este ejercicio mediante el uso de arrays. En este caso se trata de resolverlo prescindiendo de arrays o vectores.

 

SOLUCIÓN:

 PROGRAMA IMPARES02 [Pseudocódigo aprenderaprogramar.com]
 
 Variables
 Enteras: E, Dato
 
 1. Inicio
 
 2. Mientras E <> 4 Hacer
      2.1 Si E = 1 Entonces
            Llamar EntrarDato
            FinSi
      2.2 Si E = 2 y Dato <> 0 Entonces
            Llamar CalculaSuma(Dato) PorValor
            FinSi
      2.3 Si E = 3 y Dato <> 0 Entonces
            Llamar CalculaMult(Dato) PorValor
            FinSi
      2.4 Mostrar “Elija opción: 1. Introducir dato  
                                         2. Calcular 1 + 3 + 5 + ··· + n
                                         3. Calcular 1 * 3 * 5 * ··· * n
                                         4. Salir”
      2.5 Pedir E
 Repetir
 
3. Fin
 
 Módulo EntrarDato
 
 Variables
 Booleanas: Par
 
 1. Dato = 0
 2. Mientras Dato < = 0 ó Dato > 19 ó Par = Verdadero Hacer
 Par = Falso
 Mostrar “Introduzca un número impar entre 1 y 19”
 Pedir Dato
 Si Dato mod 2 = 0 Entonces
      Par = Verdadero
      Mostrar “El número debe ser impar”
 FinSi
 Repetir
 
 3. Mostrar “Dato aceptado”
 
 FinMódulo

 

 Módulo CalculaSuma(Numero: Enteros) [Pseudocódigo aprenderaprogramar.com]
 
 Variables
 Enteras: Impar, Suma
 
 1. Impar = - 1 : Suma = 0   (1)
 2. Hacer
         Impar = Impar + 2
         Suma = Suma + Impar
     Repetir Mientras Impar < Numero
 
 3. Mostrar “La suma 1 + 3 + 5 + ··· + n vale”, Suma
 
 FinMódulo
 
 Módulo CalculaMult(Cifra: Enteros)
 
 Variables
 Enteras: Impar, Acumulado
 
 1. Impar = - 1 : Acumulado = 1
 2. Hacer
        Impar = Impar + 2
        Acumulado = Acumulado * Impar
     Repetir Mientras Impar < Cifra
 3. Mostrar “El producto 1 * 3 * 5 * ··· * n vale”, Acumulado
 
 FinMódulo
 


(1)Nota: Suma = 0 redundante
 
 einstein y los numeros

Ilustración: Hemos de prever cuál va a ser el funcionamiento de nuestros programas para evitar procesos más “pesados” de los que un ordenador pueda asumir.

 

Diagrama de flujo:

diagrama de flujo programa

 

 

    

 

 

 

Para acceder a la información general sobre este curso y al listado completo de entregas pulsa en este link:  Ver curso completo.

Para  hacer un comentario o consulta utiliza los foros aprenderaprogramar.com, abiertos a cualquier persona independientemente de su nivel de conocimiento.

Bajar archivo...
ArchivoInformación adicional:Tamaño de archivoDescargas
Descargar este archivo (CU00217A Ejercicio serie suma terminos sucesion y multiplicacion n impares I.pdf)CU00217A Ejercicio serie suma terminos sucesion y multiplicacion n impares I.pdfFormato pdf110 Kb6806

¿Puedo yo aprender?

Seas o no del área informática, si quieres aprender a programar te ofrecemos una solución guiada y personalizada: realizar un curso tutorizado on-line. Con este tipo de curso, podrás aprender a programar de forma ágil y amena.

Acceder a detalles y precios de los cursos tutorizados on-line

Política sobre cookies

Utilizamos cookies propias y de terceros para ofrecerte una mejor experiencia y servicio, de acuerdo a tus hábitos de navegación.

Si continúas navegando, consideramos que aceptas su uso. Puedes obtener más información en nuestra Política de Cookies.

En Facebook!

Ahora puedes seguirnos en Facebook. Noticias, novedades y mucho más ¡Te esperamos!

RANKING APR2+

Ranking de lenguajes y entornos de programación aprenderaprogramar.com
 

ENERO - FEBRERO 2017

1. Java / J2EE
2. Entornos Oracle
3. .NET, C#
4. JavaScript, jQuery
5. Entornos SQL Server
6. HTML, CSS
7. Php, MySql
8. Android, iOS


Acceder a detalles sobre el ranking de programación aprenderaprogramar.com

Encuesta lenguajes

¿Sobre qué lenguaje te gustaría que trataran los próximos cursos de aprenderaprogramar.com?

FOROS APR2+

Pregunta, responde, consulta, lee, intercambia...

Participa!!! Entra en los foros aprenderaprogramar.com.